Symptom:
Revit (any version can be affected with this error) cannot see the REVITHOSTSERVER when attempting to open a model from Revit Server.
Cause:
This error is caused by a missing (or blank) RSN.ini file located at C:\ ProgramData\Autodesk\Revit Server *version*\Config.
Resolution:
- Check in one of the other version folders and copy an existing one to the problem version path (it is not version specific)
- Create a new one using notepad (named RSN.ini) and containing the information REVITHOSTSERVER
Notes:
This can be done remotely without user interruption and will work without closing and reopening Revit.